如何绕过Firefox 4.0 Beta的不兼容的附加组件错误和安装扩展无论如何

最新的Firefox Beta是相当可怕的,在顶部的选项卡,和一个新的菜单,看起来像一个可怕的很多像Opera。 这一切都很顺利,直到你尝试并安装你还没有更新的喜欢的扩展。 这里是如何强迫他们工作。

这里是我们正在谈论的错误消息:

image[6]

附注:想自己测试新的测试版? 转到Firefox Beta网站 ,虽然它真的是测试版,并有很多变化,所以你会想在你这么做之前仔细考虑。

image

打开about:config页面,然后右键单击任何地方,并选择New - > Boolean。

image

你会得到一个弹出菜单,在这一点,你会想使用两个值之一作为首选项名称,具体取决于您使用的版本:

4.0 Beta: extensions.checkCompatibility.4.0b

4.0发布: extensions.checkCompatibility.4.0

image

然后将值设置为false。

image

在这一点上你的扩展应该安装只是...

image

重要说明:在撰写本文时,Greasemonkey实际上与Firefox 4.0测试版不兼容,并且不断打开主页,其中包含一个永无止境的标签列表。 对于我们测试的很多扩展也是如此,虽然其中一些工作正常。 我们相信他们很快就会更新。

赞 (0)
分享到:更多 ()