看看在Ubuntu上安装了什么版本的软件包

Ubuntu上的包管理系统使安装和删除包非常简单,但有时需要确定实际安装的特定包的版本。

apt-get实用程序只是debian dpkg实用程序的前端,实际上是真正的工作。 您可以使用此实用程序找出安装的是什么版本。

dpkg -s <packagename>

这里有一个例子,我试图找出我在我的系统上安装了什么版本的Ruby:

geek @ ubuntuServ:〜$ dpkg -s ruby​​1.8

软件包:ruby1.8
状态:安装ok安装
优先级:可选
章节:口译员
安装尺寸:272
维护者:Ubuntu核心开发者<ubuntu-devel@lists.ubuntu.com>
建筑:i386
版本:1.8.4-5ubuntu1.2
取决于:libc6(> = 2.4-1),libruby1.8(> = 1.8.4)
建议:ruby1.8-examples,rdoc1.8,ri1.8
描述:面向对象的脚本语言Ruby 1.8的解释器
Ruby是快速简单的解释性脚本语言
面向对象编程。 它有许多功能来处理文本
文件和做系统管理任务(如perl)。 很简单,
直接,可扩展。

这个包提供了1.8版本的Ruby系列。

在Debian上,Ruby 1.8作为单独的软件包提供。 你可以得到
通过安装以下软件包完整的Ruby 1.8发行版。

ruby1.8 ruby​​1.8-dev ri1.8 rdoc1.8 irb1.8 ruby​​1.8-elisp
ruby1.8-examples libdbm-ruby1.8 libgdbm-ruby1.8 libtcltk-ruby1.8
libopenssl-ruby1.8 libreadline-ruby1.8
原始维护者:akira yamada <akira@debian.org>

你可以看到我已经安装了1.8.4版本。

赞 (0)
分享到:更多 ()