解决Plesk Watchdog的“警告:SSH版本1可能”

这个提示不会对每个人都有用,但对于任何具有专用服务器的人,您可能会熟悉每周从服务器上的安全扫描程序发送的此错误消息。

我从“看门狗”每周一次看到的错误电子邮件如下所示:

安全扫描生成以下警告(完整扫描日志
在/var/log/rkhunter.log中可用):

[01:01:51] ---------安全建议---------
[01:01:52]警告:可能允许SSH版本1!

要解决这个问题,我们需要编辑sshd_config文件,这是sshd服务的主要配置文件。 该位置有时会不同,但通常位于/ etc / ssh /中。 以root身份登录时打开文件。

注意:小心,如果你拧这个你不能ssh到你的服务器了...

vi / etc / ssh / sshd_config

在文件中找到此部分,其中包含“协议”行。 这里是问题的位置...我们需要明确告诉sshd服务只使用版本2。

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

如果该行被注释掉或有两个2,1在其中,你需要使它看起来像这样(保留其他行单独)

协议2

现在您需要重新启动sshd服务:

/etc/init.d/sshd restart

你不应该得到那些错误的电子邮件了。

赞 (0)
分享到:更多 ()